LoFP LoFP / very long command line arguments may contain these keywords in irrelevant sections of the code.

Techniques

Sample rules

Windows Private Keys Discovery

Description

The following analytic identifies processes that retrieve information related to private key files, often used by post-exploitation tools like winpeas. This detection leverages data from Endpoint Detection and Response (EDR) agents, focusing on command-line executions that search for private key certificates. This activity is significant as it indicates potential attempts to locate insecurely stored credentials, which adversaries can exploit for privilege escalation, persistence, or remote service authentication. If confirmed malicious, this behavior could allow attackers to access sensitive information, escalate privileges, or maintain persistence within the compromised environment.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

FROM datamodel=Endpoint.Processes WHERE

Processes.process_name IN (
    "cmd.exe",
    "findstr.exe",
    "powershell.exe",
    "pwsh.exe"
)
Processes.process IN (
    "*.asc*",
    "*.cer*",
    "*.csr*",
    "*.der*",
    "*.gpg*",
    "*.key*",
    "*.ovpn*",
    "*.p12*",
    "*.p12*",
    "*.p7b*",
    "*.pem*",
    "*.pfx*",
    "*.pgp*",
    "*.ppk*",
    "*.rdg*"
)

BY Processes.action Processes.dest Processes.original_file_name
   Processes.parent_process Processes.parent_process_exec Processes.parent_process_guid
   Processes.parent_process_id Processes.parent_process_name Processes.parent_process_path
   Processes.process Processes.process_exec Processes.process_guid
   Processes.process_hash Processes.process_id Processes.process_integrity_level
   Processes.process_name Processes.process_path Processes.user
   Processes.user_id Processes.vendor_product


| `drop_dm_object_name(Processes)`


| regex process="(?i)[^\.\-\_\$a-zA-Z](dir\s
|findstr)"

| regex process="(?i)\.(?:rdg
|gpg
|pgp
|p12
|der
|csr
|cer
|ovpn
|key
|ppk
|p12
|pem
|pfx
|p7b
|asc)\b"


| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_private_keys_discovery_filter`