LoFP LoFP / this windows feature may be implemented by an administrator on some servers where shutdown is restricted. in that scenario, filtering by the machines and users allowed to modify this registry key is recommended.

Techniques

Sample rules

Windows Disable Shutdown Button Through Registry

Description

The following analytic detects suspicious registry modifications that disable the shutdown button on a user’s logon screen. It leverages data from the Endpoint.Registry data model, specifically monitoring changes to registry paths associated with shutdown policies. This activity is significant because it is a tactic used by malware, particularly ransomware like KillDisk, to hinder system usability and prevent the removal of malicious changes. If confirmed malicious, this could impede system recovery efforts, making it difficult to restart the machine and remove other harmful modifications.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

FROM datamodel=Endpoint.Registry WHERE

(
    (
    Registry.registry_path= "*\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Policies\\System\\shutdownwithoutlogon"
    Registry.registry_value_data = "0x00000000"
    )
OR
    (
        Registry.registry_path="*\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Policies\\Explorer\\NoClose"
        Registry.registry_value_data = "0x00000001"
    )
)

by Registry.action Registry.dest Registry.process_guid Registry.process_id
   Registry.registry_hive Registry.registry_path Registry.registry_key_name
   Registry.registry_value_data Registry.registry_value_name
   Registry.registry_value_type Registry.status
   Registry.user Registry.vendor_product


| `drop_dm_object_name(Registry)`

| where isnotnull(registry_value_data)

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_disable_shutdown_button_through_registry_filter`