LoFP LoFP / this behavior is not commonly seen in production environment and not advisable, investigate the activity and determine if it is malicious. apply additional filters to reduce false positives as needed.

Techniques

Sample rules

Windows Set Account Password Policy To Unlimited Via Net

Description

The following analytic detects the use of net.exe or net1.exe to configure the Windows maximum password age policy as unlimited. It leverages process creation telemetry from Endpoint Detection and Response (EDR) agents and identifies executions of the net accounts command using the /maxpwage:unlimited option. When specified, Windows configures the maximum password age with an unlimited value, effectively preventing passwords governed by the affected password policy from expiring. This behavior is significant because an adversary may modify password expiration settings to weaken credential security controls and maintain access to compromised accounts for an extended period. If confirmed malicious, this activity may indicate an attempt to establish or maintain persistence by preventing expected password rotation from invalidating credentials under the affected password policy.

Detection logic


| tstats `security_content_summariesonly`
  values(Processes.process) as process min(_time) as firstTime max(_time) as lastTime

FROM datamodel=Endpoint.Processes WHERE

`process_net`
Processes.process="* accounts *"
Processes.process IN ("* /maxpwage:unlimited*")

BY Processes.action Processes.dest Processes.original_file_name
   Processes.parent_process Processes.parent_process_exec Processes.parent_process_guid
   Processes.parent_process_id Processes.parent_process_name Processes.parent_process_path
   Processes.process Processes.process_exec Processes.process_guid
   Processes.process_hash Processes.process_id Processes.process_integrity_level
   Processes.process_name Processes.process_path Processes.user
   Processes.user_id Processes.vendor_product


| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_set_account_password_policy_to_unlimited_via_net_filter`