LoFP LoFP / symantec host integrity check uses jscript through cscript.exe

Techniques

Sample rules

Jscript Execution Using Cscript App

Description

The following analytic detects the execution of JScript using the cscript.exe process. It leverages data from Endpoint Detection and Response (EDR) agents, focusing on process and command-line telemetry. This behavior is significant because JScript files are typically executed by wscript.exe, making cscript.exe execution unusual and potentially indicative of malicious activity, such as the FIN7 group’s tactics. If confirmed malicious, this activity could allow attackers to execute arbitrary scripts, leading to code execution, data exfiltration, or further system compromise.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

FROM datamodel=Endpoint.Processes WHERE
(
    (
        Processes.parent_process_name = "cscript.exe"
        Processes.parent_process = "*//e:jscript*"
    )
    OR
    (
        Processes.process_name = "cscript.exe"
        Processes.process = "*//e:jscript*"
    )
)

NOT Processes.process="*/Job:AgentHIScript*"
NOT Processes.parent_process="*/Job:AgentHIScript*"

BY Processes.action Processes.dest Processes.original_file_name
   Processes.parent_process Processes.parent_process_exec Processes.parent_process_guid
   Processes.parent_process_id Processes.parent_process_name Processes.parent_process_path
   Processes.process Processes.process_exec Processes.process_guid
   Processes.process_hash Processes.process_id Processes.process_integrity_level
   Processes.process_name Processes.process_path Processes.user
   Processes.user_id Processes.vendor_product


| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `jscript_execution_using_cscript_app_filter`