LoFP LoFP / some legitimate users may run iobit unlocker to manage locked files for maintenance or troubleshooting. filter detections for approved use to reduce false alerts.

Techniques

Sample rules

Windows IOBit Unlocker Extension DLL Registration via Regsvr32

Description

Detects the IOBit Unlocker Extension being registered. IObit Unlocker is a utility designed to resolve issues involving files or folders that cannot be deleted, moved, or renamed due to being locked by other processes or applications in Windows. It’s a powerful tool that can “unlock” these files or folders, terminating any processes that are using them. This allows users to manipulate these previously inaccessible files or folders as needed.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

from datamodel=Endpoint.Processes where

Processes.process="*IObitUnlockerExtension.dll*"
Processes.process_name="regsvr32.exe"

by Processes.process Processes.vendor_product Processes.user_id Processes.process_hash
   Processes.parent_process_name Processes.parent_process_exec Processes.action
   Processes.dest Processes.process_current_directory Processes.process_path
   Processes.process_integrity_level Processes.original_file_name Processes.parent_process
   Processes.parent_process_path Processes.parent_process_guid Processes.parent_process_id
   Processes.process_guid Processes.process_id Processes.user Processes.process_name


| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_iobit_unlocker_extension_dll_registration_via_regsvr32_filter`