Techniques
Sample rules
Windows Metasploit Confluence Plugin Execution
- source: splunk
- technicques:
- T1608
- T1505.003
- T1190
Description
Detects the malicious java plugin execution used by metasploit for Atlassian Confluence exploitation. This usually leads to the download of meterpreter giving the actor full control over the Confluence server.
Detection logic
| tstats `security_content_summariesonly`
count min(_time) as firstTime
max(_time) as lastTime
from datamodel=Endpoint.Processes where
Processes.process_path="*\\Atlassian\\Confluence\\jre\\bin\\java.exe"
Processes.process="*-classpath *"
Processes.process="*\\AppData\\Local\\Temp\\~spawn*"
Processes.process="*.Payload*"
by Processes.process Processes.vendor_product Processes.user_id Processes.process_hash
Processes.parent_process_name Processes.parent_process_exec Processes.action
Processes.dest Processes.process_current_directory Processes.process_path
Processes.process_integrity_level Processes.original_file_name Processes.parent_process
Processes.parent_process_path Processes.parent_process_guid Processes.parent_process_id
Processes.process_guid Processes.process_id Processes.user Processes.process_name
| `drop_dm_object_name(Processes)`
| `security_content_ctime(firstTime)`
| `security_content_ctime(lastTime)`
| `windows_metasploit_confluence_plugin_execution_filter`