LoFP LoFP / occasional administrative scripts or automated tasks might execute commands in the iis directory. these instances are rare but should be verified before raising alerts.

Techniques

Sample rules

Windows Shell or Script Execution From IIS Directory

Description

Detects Windows command tools such as cmd, PowerShell, or pwsh being executed from the IIS installation directory. This can be indicative of exploitation of software reliant on IIS such as Exchange.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

from datamodel=Endpoint.Processes where

Processes.process_current_directory="*:\\Windows\\System32\\inetsrv\\*"
Processes.parent_process_name IN (
    "cmd.exe",
    "powershell.exe",
    "pwsh.exe"
)

by Processes.process Processes.vendor_product Processes.user_id Processes.process_hash
   Processes.parent_process_name Processes.parent_process_exec Processes.action
   Processes.dest Processes.process_current_directory Processes.process_path
   Processes.process_integrity_level Processes.original_file_name Processes.parent_process
   Processes.parent_process_path Processes.parent_process_guid Processes.parent_process_id
   Processes.process_guid Processes.process_id Processes.user Processes.process_name


| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_shell_or_script_execution_from_iis_directory_filter`