LoFP LoFP / - mcafee related services changes are a known false positive. the sc.exe utility is used to deny groups such as authenticated users, built-in administrators and system access to certain permissions.

Techniques

Sample rules

Windows New Deny Permission Set On Service SD Via Sc.EXE

Description

The following analytic detects changes in a service security descriptor where a new deny ace has been added. It leverages data from Endpoint Detection and Response (EDR) agents, specifically searching for any process execution involving the “sc.exe” binary with the “sdset” flag targeting any service and adding a dedicated deny ace to specific groups. If confirmed malicious, this could allow an attacker to escalate their privileges, blind defenses and more. Investigate appropariate services and groups to determine if the behavior is malicious.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime
        values(Processes.process) as process
FROM datamodel=Endpoint.Processes WHERE
(
    Processes.process_name=sc.exe
    OR
    Processes.original_file_name=sc.exe
)
Processes.process="*sdset *"
Processes.process="*(D;*"
Processes.process IN (
    "*;IU*",
    "*;S-1-5-4*",
    "*;SU*",
    "*;S-1-5-6*",
    "*;BA*",
    "*;S-1-5-32-544*",
    "*;SY*",
    "*;S-1-5-18*",
    "*;WD*",
    "*;S-1-1-0*",
    "*;AU*",
    "*;S-1-5-11*",
    "*;LS*",
    "*;S-1-5-19*"
)
BY Processes.action Processes.dest Processes.original_file_name
   Processes.parent_process Processes.parent_process_exec
   Processes.parent_process_guid Processes.parent_process_id
   Processes.parent_process_name Processes.parent_process_path
   Processes.process Processes.process_exec Processes.process_guid
   Processes.process_hash Processes.process_id Processes.process_integrity_level
   Processes.process_name Processes.process_path Processes.user
   Processes.user_id Processes.vendor_product

| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `windows_new_deny_permission_set_on_service_sd_via_sc_exe_filter`