Techniques
Sample rules
Windows Netspy Network Scanner Execution
- source: splunk
- technicques:
- T1595
- T1018
Description
Detects usage of the Netspy scanner on an endpoint. Netspy is a lightweight, fast, and cross-platform tool designed for internal network segment discovery. The tool supports various protocols, including ICMP, ARP, TCP, and UDP, allowing users to scan for active hosts and services within predefined IP ranges.
Detection logic
| tstats `security_content_summariesonly`
count min(_time) as firstTime
max(_time) as lastTime
from datamodel=Endpoint.Processes where
Processes.process_name="netspy.exe"
Processes.process IN (
"*arpspy*",
"*as*",
"*icmpspy*",
"*is*",
"*pingspy*",
"*ps*",
"*tcpspy*",
"*ts*",
"*udpspy*",
"*us*"
)
by Processes.process Processes.process_name Processes.user_id Processes.process_hash
Processes.parent_process_name Processes.parent_process_exec Processes.action
Processes.dest Processes.process_current_directory Processes.process_path
Processes.process_integrity_level Processes.original_file_name Processes.parent_process
Processes.parent_process_path Processes.parent_process_guid Processes.parent_process_id
Processes.process_guid Processes.process_id Processes.user Processes.vendor_product
| `drop_dm_object_name(Processes)`
| `security_content_ctime(firstTime)`
| `security_content_ctime(lastTime)`
| `windows_netspy_network_scanner_execution_filter`