LoFP LoFP / legitimate administrative scripts, mdm workflows, software deployment tools, developer automation, or support utilities may use osascript to invoke an interactive shell.

Techniques

Sample rules

MacOS Osascript Executing Interactive Shell

Description

This analytic detects the macOS osascript utility being used with an interactive Bash invocation, identified by the presence of “bash -i” in the command line. Adversaries may abuse osascript and AppleScript’s shell execution capabilities to launch interactive shells, establish remote access, or execute post-exploitation commands.

Detection logic


| tstats `security_content_summariesonly`
  count min(_time) as firstTime
        max(_time) as lastTime

FROM datamodel=Endpoint.Processes WHERE

Processes.process_name="osascript"
Processes.process="*bash *"
Processes.process="* -i*"

BY Processes.action Processes.dest Processes.parent_process Processes.parent_process_exec
    Processes.parent_process_guid Processes.parent_process_id
    Processes.parent_process_name Processes.parent_process_path
    Processes.process Processes.process_exec Processes.process_guid
    Processes.process_hash Processes.process_id Processes.process_integrity_level
    Processes.process_name Processes.process_path Processes.user
    Processes.user_id Processes.vendor_product


| `drop_dm_object_name(Processes)`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `macos_osascript_executing_interactive_shell_filter`