LoFP LoFP / false positives may be present based on file version, modify the analytic to only look for version between 18.12.407 and 18.12.416 as needed.

Techniques

Sample rules

Windows Vulnerable 3CX Software

Description

The following analytic detects instances of the 3CXDesktopApp.exe with a FileVersion of 18.12.x, leveraging Sysmon logs. This detection focuses on identifying vulnerable versions 18.12.407 and 18.12.416 of the 3CX desktop app. Monitoring this activity is crucial as these specific versions have known vulnerabilities that could be exploited by attackers. If confirmed malicious, exploitation of this vulnerability could lead to unauthorized access, code execution, or further compromise of the affected system, posing significant security risks.

Detection logic

`sysmon` (process_name=3CXDesktopApp.exe OR OriginalFileName=3CXDesktopApp.exe)  FileVersion=18.12.*
  
| stats count min(_time) as firstTime max(_time) as lastTime
    BY action dest original_file_name
       parent_process parent_process_exec parent_process_guid
       parent_process_id parent_process_name parent_process_path
       process process_exec process_guid
       process_hash process_id process_integrity_level
       process_name process_path user
       user_id vendor_product
  
| `security_content_ctime(firstTime)`
  
| `security_content_ctime(lastTime)`
  
| `windows_vulnerable_3cx_software_filter`