LoFP LoFP / administrators add legitimate corporate domains during onboarding or m&a.

Techniques

Sample rules

OpenAI ChatGPT Enterprise Domain Created

Description

Detects ChatGPT Enterprise audit events that create a workspace domain boundary entry. Domain changes can expand who is allowed to join or access the tenant and may establish persistence for attacker-controlled domains.

Detection logic

from logs-openai_chatgpt_enterprise.audit_log-* metadata _id, _version, _index
| where
    data_stream.dataset == "openai_chatgpt_enterprise.audit_log" and
    event.action == "domain_create"
| keep
    _id, _version, _index, @timestamp, event.action, user.id, user.email, source.ip,
    openai_chatgpt_enterprise.audit_log.action_data.hostname,
    openai_chatgpt_enterprise.audit_log.action_data.domains,
    openai_chatgpt_enterprise.audit_log.action_data.domain_id,
    openai_chatgpt_enterprise.audit_log.action_privilege, data_stream.*