LoFP LoFP / administrator or network operator may execute this command. please update the filter macros to remove false positives.

Techniques

Sample rules

Ping Sleep Batch Command

Description

The following analytic identifies the execution of ping sleep batch commands. It leverages data from Endpoint Detection and Response (EDR) agents, focusing on process and parent process command-line details. This activity is significant as it indicates an attempt to delay malicious code execution, potentially evading detection or sandbox analysis. If confirmed malicious, this technique allows attackers to bypass security measures, making it harder to detect and analyze their activities, thereby increasing the risk of prolonged unauthorized access and potential data exfiltration.

Detection logic


| tstats `security_content_summariesonly` count min(_time) as firstTime max(_time) as lastTime FROM datamodel=Endpoint.Processes
  WHERE (
        Processes.parent_process= "*ping*" Processes.parent_process = *-n* Processes.parent_process="* Nul*" Processes.parent_process IN ("*>*", "*>*") Processes.parent_process IN ("*&*", "*& *")
    )
    OR ( Processes.process = "*ping*" Processes.process = *-n* Processes.process="* Nul*" Processes.process IN ("*>*", "*>*") Processes.process IN ("*&*", "*& *") )
  BY Processes.action Processes.dest Processes.original_file_name
     Processes.parent_process Processes.parent_process_exec Processes.parent_process_guid
     Processes.parent_process_id Processes.parent_process_name Processes.parent_process_path
     Processes.process Processes.process_exec Processes.process_guid
     Processes.process_hash Processes.process_id Processes.process_integrity_level
     Processes.process_name Processes.process_path Processes.user
     Processes.user_id Processes.vendor_product

| `drop_dm_object_name("Processes")`

| `security_content_ctime(firstTime)`

| `security_content_ctime(lastTime)`

| `ping_sleep_batch_command_filter`